| Forums | Register | Polls | Search | Statistics |
You must be logged in to post content on this forum.
PGenerator & DeviceControl Light Illusion Forums / PGenerator & DeviceControl /  

PGenerator – Connectivity Guide Wi-Fi & Bluetooth

Page  Page 1 of 4:  1  2  3  4  Next »

Author churd60041
#1 | Posted: 1 Mar 2019 09:23 
Here is a link to the RPi PGenerator developer ( https://www.avmagazine.it/forum/88-calibrazione-proiettori-e-display/301272-rpg-rpi-p attern-generator-by-biasi ) – at this web site, using a Raspberry Pi 3 or 3+, you will find instructions for how to build and operate an excellent and accurate Test Pattern Generator. More on the accuracy of this device at the end of this guide. This TPG works seamlessly with LightSpace. The RPi PGenerator is also quite flexible when it comes to wireless connectivity.

The purpose of this guide. To share my experience regarding the RPi PGenerator connectivity.
There are (4) ways to connect the PGenerator (using Raspberry Pi 3 or 3+).
(1) Ethernet, (2) Wi-Fi as an Access Point, (3) Wi-Fi using Network/Router, (4) Bluetooth

Assumptions - Is that you have a Raspberry Pi, imaged the OS to your SD card and you have the PGenerator working. Configuring and managing the RPi PGenerator requires MS Windows support (Device Control). You already have downloaded Device Control (zip file). If not, it is provided, by the developer, with the link above.

Connect an ethernet cable between your router and the RPi. LightSpace will recognize the device via the assigned IP address given by your router. Go to Network Screen – press enable. Works well. My router is not close to my TVs for that reason I prefer to use other connectivity measures.

Wi-Fi as an Access Point:
This is always enabled when you power up the RPi and will show up in your PC network connections as "PGENERATOR'. Press connect, you will be asked for a password which is the same name – PGenerator). Next, open LightSpace and your Network Screen – click on Enable – LightSpace will show address ( You are now connected. Limitation of this method is that you will not have Internet access, while calibrating your TV, since you have connected your PC network to the PGenerator. Works quite well.

Wi-Fi using Network/Router:
1. This is not enabled. You will have to configure the RPi, using Device Control, to turn this feature on. Once it is on, it is always on and available as another option for connectivity.
2. Like any other home Wi-Fi connected device your router will ask for and assign a name, IP address and password.
3. Using Device Control, you will configure the RPi with the name and password.
4. Once setup, this works quite well plus you still have internet connection if needed.
5. Open LightSpace and Network Screen – press enable. If working properly you will see IP address added as a client (example You are now connected.
Pleas reference developer site and make sure you know how to access and use Device Control.

· Bluetooth is always on and available.
· This would be the recommended path to connectivity. Provides a stable connection especially needed when doing long LUT calibrations. As long as devices are paired and connected you are good to go.
· As a Windows user, – Go to your Laptop/PC and find the Bluetooth Icon (lower right corner, hidden icons)
· Right Click Bluetooth Icon>Click Add Device > Find Device > Connect Device.
· Go to LightSpace (Network Screen) – press enabled.
 You should now see a new address (example: as a client – BLUETOOTH now ENABLED.

Note: PGenerator Accuracy - I provide the following link ( https://www.avsforum.com/forum/139-display-calibration/3023002-cheap-test-pattern-gen erators-accuracy-thread.html ) – Here you will find independent tests done comparing apple 4ktv, firestick and RPi against reference method – quite amazing the accuracy of this device. Make sure you configure RPi PGenerator for HDMI output as RGB Full. This is pointed out and explained in the tests done.

Note: Portability of PGenerator - Yes, you can connect the RPi PGenerator to a power bank and it will last about 7 hours. Power Bank can be purchased on amazon: (I have one and it works very well). No need for power cord.
EasyAcc Power Bank 6000mAh Portable Charger with Built-in Micro USB Cable Ultra Slim External Battery Pack by EasyAcc

I hope this helps. I have done a lot of reading on sites like this and appreciate those that know sharing their expertise. Again, if you have questions – please PM message the developer at his site. I have worked with him (Ric) and he is very willing to help in any way. Truly a very good person!

Author ryu
#2 | Posted: 25 Mar 2019 23:49 
Hi everyone.

I can't connect to bluetooth at all. My PC detects PGenerator, however it won't connect. Don't know the pin either, tried PGenerator, PGenerator!!$, and such, with no results. Device control shows BT with invalid mac address - AA:AA:AA:AA:AA, don't know how to fix it, tried reinstalling bluez using putty but it didn't work either. Using lightspace through wifi, it seems to not keep sync with the images generated.

Hope anyone can help me.

Author biasi
#3 | Posted: 26 Mar 2019 09:19 
you need to reboot the device and add it in Bluetooth Personal Area Network (Right-click the Bluetooth Devices notification area icon and choose Join a Personal Area Network);when the device is recognized and added in Personal Area Network you can connect to it and the PGenerator will be reachable with ip

Author churd60041
#4 | Posted: 26 Mar 2019 12:14 
You can connect the RPi in many ways as I suggest above. One is via Bluetooth and the RPi developer (biasi) explains that well. Follow biasi instructions if you would rather connect using bluetooth. If not, you can connect with the PGenerator that your PC detected (RPi as a wi-fi access point not bluetooth) - two separate ways.

The PGenerator (as detected on your PC) act as a Wi-Fi access point (AP). This is what you are doing When you say "My PC detects or sees the PGenerator" - it is doing that to let you know that it is available as a Wi-Fi access point. Just click on PGenerator (make take a minute to connect). When it says connected you are ready to use RPi with any PC cal software you are using (i.e. HCFR, LightSpace or Calman). Just remember if you go this route, the calibrating software will want to know the ip address to connect to your Wi-Fi access point - For this type connection the ip is - side note: when you connect this way (i.e. with PGenerator) you lose internet connection. To get internet connection back you will disconnect PGenerator and connect through your normal wi-fi connection.

The ip address for bluetooth connection is - not the same as wi-fi AP I describe above.
ryu, you can always ask to do PM message with Biasi - he is the developer and will work with you on the side if needed. This is how I learned by working with him.

Author ryu
#5 | Posted: 28 Mar 2019 18:18 
Thank you both for the help!
I have no problem connecting through wifi, however when i use lightspace to profile it doesn't keep in sync. Sometimes the pattern just freezes for a while and then sends all images through too fast (i'm using the recommended 0.25 delay). As your guide said BT is the most stable, I tried connecting that way, however even after adding it as the developer biasi said (thanks once again!), lightspace won't detect it. I think the problem is raspberry 3 with bluez 5.41 as several posts on the net talks about the issue, they say to downgrade bluez to 5.23 or so because the BT mac address as it is, just stays AA:AA:AA:AA:AA, and i can't connect to it whatsoever. As of now, i just flashed a clean PGenerator install and i'm updating once again, however the mac address is the same as i said above, and even before the pkg_update command i couldn't use BT.

On a side note, is it possible to make PGenerator compatible with berryboot? Tried that also to no avail.

Author Steve

#6 | Posted: 28 Mar 2019 18:28 
Sounds like a WiFi network interrupt issue.
It is not a known LightSpace issue.
I would change your router.

Steve Shaw
Mob Boss at Light Illusion

Author churd60041
#7 | Posted: 28 Mar 2019 18:57 
Your questions and issues are now better answered by the developer (Biasi). He reads these posts and I am sure he will get back with you.
If you can, leave Biasi and PM to work with you privately.

Author ryu
#8 | Posted: 1 Apr 2019 20:41 
Hello again!
I've had the amazing help from Biasi!
It was a issue with my bt dongle, it seems it has an old specification. However he also made several modifications due to the MAC address problem, that was because of bluez version + raspberry pi b3+. Biasi had updated the bluez package to version 5.5.
In order to get it to work it would be nice to update the PGenerator using Putty:
1) Logon putty: user: root | password: PGenerator!!$
2) run pkg_update command
Check this page if you don't know how to use Putty

Then you can do the following to get BT working.
1) Add PGenerator to your personal network: bluetooth icon -> join personal network -> add device -> pgenerator.
2) Set PGegerator as an access point
3) You can now manage it with device control.

I think that's it.
I would like to thank you all, and a special thank you to Biasi, who spent quite sometime helping me and fixing it.

Now i'm going to try the multiboot, i'll report back as soon as I can.

Author Wboshart
#9 | Posted: 2 Apr 2019 20:23 
My computer recognizes my pi's Bluetooth and will connect to it. I can even set it up as an access point in the Bluetooth menu, but when I enable network settings in lightspace it doesn't show up as an available source, nothing does unless I have the pi connected via lan or if I access it as a WiFi access point. I did update to the latest pgenerator firmware too. Curious what I might be missing or doing wrong?

Author biasi
#10 | Posted: 12 Apr 2019 09:23 
from a command prompt execute,when the computer is connected to rpi with access point,the following command:
if the ping is ok on your pc a firewall rule is missing and you need to add a "program firewall rule" to allow Lightspace to connect to your pc
if the ping is not ok please:
update the firmware with pkg_update, reboot the device and check if now all is ok
if there is still the problkem execute the command: hciconfig and check if there is a macaddress correct or AA:AA...

Author stuart_p
#11 | Posted: 20 Apr 2019 11:29 
HI. Couple of things. The RPi on WIn10 doesn't automatically use that IP address. Use ipconfig to see the address of the Bluetooth device. For me it was You can change it to in the IPv4 properties. The issue that I have and yet to get sorted is that when you select the Bluetooth device to the Personal Area Network, Win 10 kindly sees it as an Unidentified Network and as such labels it Public and so it will not connect to Lightspace until it can be made Private. The difficulty is that it doesn't appear as a standard Ethernet or Wifi where you can change it to Private and get through the firewall. I have tried numerous methods deamed to work and as yet no go. But still trying. Any network geniuses out there with some advise would be very welcome.

Author biasi
#12 | Posted: 20 Apr 2019 15:33 
you can create a new "program firewall input rule" to permit connection from Lightspace for public network or you can change the "Color Management System" rule permitting also public network
I suggest you also to upate raspberry software because I have done recently an update for bluetooth

Author stuart_p
#13 | Posted: 21 Apr 2019 05:59 
Thanks biasi. Yes I tried the incoming rule and also created an outgoing rule and Lightspace appears in the network settings for Private and Public. Lightspace sees the IP address in the server IP addresses but doesn't see any clients, which has always been an issue with the connection being public in my experience. The 169.254.xx address seems to indicate an issue obtaining an address with DHCP, but I manually set it to just to be consistant. I have tried resetting IP with the ipconfig /reset /renew etc etc. I even uninstalled the McAfee firewall that came with the laptop. I think the only thing left is for a nice shiraz overlooking the water....

Author stuart_p
#14 | Posted: 21 Apr 2019 06:50 
Just to be clear on the workflow just in case we are looking at this from a different perspective. Bluetooth PGenerator is paired>Bluetooth Device>Join Personal Area Network>PGenerator>Connect Using Access Point>Connection Successful. Pgenerator then appears with ipconfig etc..

Author stuart_p
#15 | Posted: 23 Apr 2019 10:00 
Just an update that may help others, especially with new Dell computers. Biasi was extremely helpful and spent extensve time from the otherside of the world figuring this out. Two issues were found. A bug in the RPi where the wrong MAC address was assigned, hence the Unidentied Network issue. Biasi wrote a script to get around this issue and I am sure he will elaborate more. So, the other issue was the dreaded McAfee. Even though McAfee was not supposedly engaged on my Dell, the fact that it came embedded with the laptop on purchase meant that like a bad virus it ignored any uninstalls with only token gesture to really rid itself from the firewall. So, for those with Dell and embedded McAfee and probably eveyone else, you need to remove McAfee with the McAfee removal tool as regadless of any rules McAfee simply gave it the finger in the backgournd. This finally allowed the RPi to be seen by LS. But beware, uninstalling McAfee caused issues for some reason with the wifi driver and in a nutshell I had to find the specific driver install for Intel Pro wireless adpator. Just doing updates didn't cut it. Thanks again Biasi

Page  Page 1 of 4:  1  2  3  4  Next » 
You must be logged in to post content on this forum.
PGenerator & DeviceControl Light Illusion Forums / PGenerator & DeviceControl /
 PGenerator – Connectivity Guide Wi-Fi & Bluetooth


Online now: Guests - 1
Members - 0
Max. ever online: 12 [12 Jan 2022 15:04]
Guests - 12 / Members - 0