| Forums | Register | Polls | Search | Statistics |
 (?)  
You must be logged in to post content on this forum.
Bugs & WIBNIs Light Illusion Forums / Bugs & WIBNIs /  
 

Stabilisation patches with FW and Secondary execution => Randomly the stabilisation patch is measured instead of the right one [Updated]

 
Author ebr9999
DPS
#1 | Posted: 2 Feb 2024 07:05 
I do hope the subject explains.
When it happens, I can see the the stabilisation patch staying longer on the panel.
It happens randomly with stabilisation set at .35 sec, Pgenerator (RPI4, Ethernet connected, Klein probe with .5 delay).
Setting the stabilisation at 0.1 sec, a greyscale makes it occurring.

I have also noted, that when the issue occurs, the problem appears also without secondary execution. Off course restarting the profile fixes it.

Author Steve

INF
Male
#2 | Posted: 2 Feb 2024 09:08 
That would seem to be a delay in the communication from the ColourSpace PC to the TPG.
Or a delay in the TPG itself.
It's not a ColourSpace bug.
You can test that by removing the TPG and using direct HDMI.

It may actually be that you need (more) Extra Delay anyway with your setup.
Stabilisation may just be making the issue more obvious, as the patch is a consistent colour.
And the FW patch may be taking longer to render in the TPG?

Steve
Steve Shaw
Mob Boss at Light Illusion

Author Steve

INF
Male
#3 | Posted: 4 Feb 2024 15:07 
I've run-up PGen, with a Secondary Execution program running too.
Nothing I do ever causes any such issue...

Steve
Steve Shaw
Mob Boss at Light Illusion

Author ebr9999
DPS
#4 | Posted: 4 Feb 2024 16:22 
Thanks for checking again.
I have also done more verifications. Yes, there is dependency on overall processing load,
I have noted the problem appeared having master and servant both doing secondary execution. I will explain in tip and trick what I have done. That's surely increase load.
Anyhow I have verified that, when it happens, there is nothing broken, i.e. reducing the load, CS returns working smoothly.

Author Steve

INF
Male
#5 | Posted: 4 Feb 2024 16:34 
Ideally, you need to test with direct HDMI.
No PGen.

Steve
Steve Shaw
Mob Boss at Light Illusion

Author ebr9999
DPS
#6 | Posted: 6 Feb 2024 05:34 
Ideally you would need an handshake with networked PG. Have you ever thought to request that to RPI4 guys?

Author Steve

INF
Male
#7 | Posted: 6 Feb 2024 07:52 
That is a question for the PGen developers.
We work with whatever API/SDK we are provided.

Steve
Steve Shaw
Mob Boss at Light Illusion

Author ebr9999
DPS
#8 | Posted: 6 Feb 2024 16:34 
I have had a quick discussion with Ricky. Pgen already acknowledges each Command and Patch request through an application (data) layer containing OK.
To be sure I have done an IP tracing that confirm what I he said to me. See below.

If you agree I can open a WIBNI

IP tracing
IP tracing

Author Steve

INF
Male
#9 | Posted: 7 Feb 2024 11:23 
The simple answer is: the information we have been provided for PGen integration included no Ack/Nak details.
We cannot implement something we know nothing about.

If we are provided full API information, we can react to it.

Steve
Steve Shaw
Mob Boss at Light Illusion

You must be logged in to post content on this forum.
Bugs & WIBNIs Light Illusion Forums / Bugs & WIBNIs /
 Stabilisation patches with FW and Secondary execution => Randomly the stabilisation patch is measured instead of the right one [Updated]

 

 
Online now: Guests - 1
Members - 1 [ Rajendra ]
Max. ever online: 192 [11 Jan 2023 08:39]
Guests - 192 / Members - 0