| Forums | Register | Polls | Search | Statistics | File Bank | 
 (?)  
You must be logged in to post content on this forum.
Bugs & WIBNIs Light Illusion Forums / Bugs & WIBNIs /  
 

Pgen 1.3 Automatic Patch setting and Limit Range bug

 
Author Lttlwing16
ZRO
#1 | Posted: 21 Aug 2022 20:23 
Two bugs I encountered today with ZRO ver. x.1472 running on Windows 10:

1 - After adjusting settings in Pgen 1.3 via CS interface and re-enabling patches with "Automatic" to use the CS patch settings, the Y pos value was not respected and the patch would return on the display to it' s default Y pos (50) position, even if the Y pos box had a different value, such as 40 or 30. To correct, the Y pos box had to be returned to 50, then back to 40 (or other custom value).

2) Selecting Limit Range while Pgen 1.3 is connected and using "Automatic" patches causes the display background outside of the patch to turn gray, even if background color was correctly set to 161616 (646464). Switching the Calibration patch to "Small" would remedy the problem and would remain so unless Automatic was re-selected AND the Limit Range was selected/deselected again.

Thanks,

David

Author liberator72
ZRO
Male
#2 | Posted: 22 Aug 2022 06:44 
Lttlwing16:
1 - After adjusting settings in Pgen 1.3 via CS interface and re-enabling patches with "Automatic" to use the CS patch settings, the Y pos value was not respected and the patch would return on the display to it' s default Y pos (50) position, even if the Y pos box had a different value, such as 40 or 30. To correct, the Y pos box had to be returned to 50, then back to 40 (or other custom value).

This is how PGenerator itself works, and it is 100% intentional.

When connected as PGenerator, ColourSpace sends the patch request, with the position of the patch in that request too. When you disable calibration patches, the "position" is no longer being sent, and PGenerator will intentionally not retain that positional information to ensure cross compatibility with all software.

When you disable calibration patches the default "central position" will be set in PGen, so when you enable them again, any patch window will be centralised on the display.

You don't (or shouldn't) need to change any X/Y pos to another value and back to your custom one. Just place your cursor into one of the X/Y pos selection boxes and press enter.

Lttlwing16:
2) Selecting Limit Range while Pgen 1.3 is connected and using "Automatic" patches causes the display background outside of the patch to turn gray, even if background color was correctly set to 161616 (646464). Switching the Calibration patch to "Small" would remedy the problem and would remain so unless Automatic was re-selected AND the Limit Range was selected/deselected again.

Try setting background to 0.0.0

Author Lttlwing16
ZRO
#3 | Posted: 23 Aug 2022 23:05 
liberator72
I mentioned to Alan, "the Y position" may be by design. Thanks for confirming.

I'll check the limit range thing next time I have my stuff out.

You must be logged in to post content on this forum.
Bugs & WIBNIs Light Illusion Forums / Bugs & WIBNIs /
 Pgen 1.3 Automatic Patch setting and Limit Range bug

 

 
Online now: Guests - 1
Members - 0
Max. ever online: 22 [12 Jul 2022 20:37]
Guests - 21 / Members - 1