| Forums | Register | Polls | Search | Statistics | File Bank | 
 (?)  
You must be logged in to post content on this forum.
Bugs & WIBNIs Light Illusion Forums / Bugs & WIBNIs /  
 

After a measurement, patch RGB values increase by +1 [Not a bug]

 
Author rajsandhu2k
ZRO
Male
#1 | Posted: 20 Jul 2022 05:44 
If you measure a patch, the RGB values will get incremented by 1. This breaks Repeat measurements. This also breaks the Measure button because now it'll add an extra unwanted point onto the graph.

The only way to work around is to reselect the patch again so that the RGB details are updated.

For example:
1) I select a patch, e.g. 90% Gray (R 229, G 229, B 229)
2) I press Measure
3) The patch gets deselected and the RGB values are incremented by +1 (R 230, G 230, B 230)

This bug only occurs with certain patches. Like with 90% Gray (229,229,229) and 70% Gray (178,178,178).

I've confirmed it's not a CSV patchlist issue. My Patch Scale is set to Full, 8 bit. If you need me to confirm anything else, please let me know.

Release: ColourSpaceZRO
Version: 1.0.0.1416 [09 June 2022]

Author Light Illusion


Male
#2 | Posted: 21 Jul 2022 08:03 
Not a bug.

Be aware that when using % values, you cannot always set the value to a numerical number, and then select %, and back to numerical, and expect the value to always remain the same, as the % values do not, and cannot, exactly match 8 bit values.

For example, 90% is not 229 - it is 230 in 8 bit.
And 70% grey is 179, not 178.

So if using a CSV list, and it has incorrect values, they will change when selecting the % option, and going back to numerical values.

Steve

Author mrtickleuk
ZRO
Male
#3 | Posted: 22 Jul 2022 12:47 
For this reason, and to remind myself, in my patchsets I don't round up the percentage values to integers in my descriptions (the optional last field).

eg:
0 ,37,37,37,9.6% Grey
1 ,53,53,53,16.9% Grey
2 ,65,65,65,22.4% Grey
3 ,70,70,70,24.7% Grey
4 ,75,75,75,26.9% Grey
5 ,80,80,80,29.2% Grey
6 ,85,85,85,31.5% Grey
7 ,90,90,90,33.8% Grey
8 ,95,95,95,36.1% Grey
9 ,100,100,100,38.4% Grey
10,105,105,105,40.6% Grey
11,126,126,126,50.2% Grey
12,142,142,142,57.5% Grey
13,158,158,158,64.8% Grey
14,174,174,174,72.1% Grey
15,190,190,190,79.5% Grey
16,198,198,198,83.1% Grey
17,206,206,206,86.8% Grey
18,222,222,222,94.1% Grey
19,235,235,235,100.0% Grey
20,255,255,255,109.1% Grey

This also reminds me why some points appear in odd places on the graphs when I look at them, and are not exactly lined up with whole integers.

Author rajsandhu2k
ZRO
Male
#4 | Posted: 26 Jul 2022 21:53 
Firstly, just to make it clear, I'm using the "Preset" mode with the CSVs. I'm not even touching the "Manual" mode. How is it messing up the numbers when I don't even have the manual % or RGB sliders on my screen??

All I'm doing is selecting a patch from the CSV, pressing Measure and then all of a sudden it increments by +1.

I'm using Ted's "21-Point Grayscale.csv" (PC levels). So I'm sure we can agree it's not a patchlist issue.

I'm not switching between any modes. I'm not using the % values. It seems like ColourSpace can't respect the CSV values. It seems to be doing some sort of internal conversion which introduces rounding errors, even when in the Presets mode.

Sorry if I didn't explain clearly in my previous post.

Author Steve

INF
Male
#5 | Posted: 27 Jul 2022 14:09 
You likely have the '%' option set to active within the Manual sliders.
That means the patch value will be 'corrected' to be the correct equivalent value, as expected.

Therefore, if the patch values are incorrect for the equivalent % value, you will see the effect you are seeing.
As above, 90% is not 229 - it is 230 in 8 bit, and 70% grey is 179, not 178.

To stop the 'correction', disable the % option.

Steve
Steve Shaw
Mob Boss at Light Illusion

Author mrtickleuk
ZRO
Male
#6 | Posted: 27 Jul 2022 15:06 
rajsandhu2k:
How is it messing up the numbers when I don't even have the manual % or RGB sliders on my screen??

As per Steve's post just now, that setting (the % option) affects things even if you are not in Manual mode. Just check what it's set to just before you press measure. Whether it's visible isn't the deciding factor.

For a more dramatic example, tick the boxes to make the R-G-B sliders lock in step together, than load any pre-set patchlist which contains colours not greys, and see how well that works... . (It's doing what you asked it to, since those options set on that screen override the requested RGB values everywhere)

Author Light Illusion


Male
#7 | Posted: 27 Jul 2022 18:51 
I should add, that when you select a patch in the 'Presets' list, it is highlighted by a grey surround.
If, after a measurement, the actual output colour changes (as discussed above, due to a value mismatch with the correct % value) the highlight will vanish, as the output colour no longer matches any patch in the .CSV Patch List.

So, ColourSpace is actually telling you the 'value' has changed.

However, while this is all working as expected, and is not a bug, I can see it's not really ideal.
We'll have a look, to see if the settings in the Manual Sliders options 'should/could' be ignored when a Preset .CSV Patch List is used.

But, mrtickleuk, I can't replicate any unexpected colour changes with the Sliders being Locked...
Can you define a workflow to show that?

Steve

Author mrtickleuk
ZRO
Male
#8 | Posted: 28 Jul 2022 11:20 
Light Illusion:
But, mrtickleuk, I can't replicate any unexpected colour changes with the Sliders being Locked...
Can you define a workflow to show that?

Apologies, it was from memory and I could very easily be wrong - just wanted to give him another example. I will check later when I get home, after I've upgraded to the new version but please take it with a pinch of salt in the meantime

Author Steve

INF
Male
#9 | Posted: 29 Jul 2022 10:18 
Ok - in the next ColourSpace build, if the % option is enabled, the Presets option will be greyed-out, and inactive.
That should stop any user confusion.

Steve

Presets Inactive
Presets Inactive
Steve Shaw
Mob Boss at Light Illusion

Author rajsandhu2k
ZRO
Male
#10 | Posted: 29 Jul 2022 21:35 
Steve:
Ok - in the next ColourSpace build, if the % option is enabled, the Presets option will be greyed-out, and inactive.

Will it work the other way around too? Like if I'm in the Presets menu, will the % option be treated as forced disabled so that it doesn't affect the patches?

If it's my fault for ticking the % box then so be it. I don't even remember ticking it. I've never even used Manual mode. But I can say, it is unintentional behaviour for the % button to be affecting patches in Preset mode.

Author Steve

INF
Male
#11 | Posted: 30 Jul 2022 07:46 
As you cannot access Presets when the % option is enabled, your question is actually irrelevant...

Steve
Steve Shaw
Mob Boss at Light Illusion

Author rajsandhu2k
ZRO
Male
#12 | Posted: 31 Jul 2022 20:14 
Awesome. Will test the updated version when it comes out and let you know what happens. Thanks for fixing

Author rajsandhu2k
ZRO
Male
#13 | Posted: 11 Aug 2022 16:38 
Tested it today - all fixed.

You must be logged in to post content on this forum.
Bugs & WIBNIs Light Illusion Forums / Bugs & WIBNIs /
 After a measurement, patch RGB values increase by +1 [Not a bug]

 

 
Online now: Guests - 1
Members - 0
Max. ever online: 22 [12 Jul 2022 20:37]
Guests - 21 / Members - 1